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Application note

Getting started with projects based on dual-core STM32H7 microcontrollers
in STM32CubelDE

Introduction

This application note describes how to get started with projects based on STM32H7 Series dual-core microcontrollers in the
STMicroelectronics STM32CubelDE integrated development environment.
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General information

1 General information

STM32CubelDE supports STM32 32-bit products based on the Arm® Cortex® processor.

Note: Arm is a registered trademark of Arm Limited (or its subsidiaries) in the US and/or elsewhere.

arm
1.1 Prerequisites

The following tools are prerequisites for understanding the tutorial in this document and developing an application
based on the STM32H7 Series:

. STM32CubelDE 1.4.0 or newer
. STM32Cube_FW_H7_V1.7.0 or newer
. STM32CubeMX 6.0.0 or newer

Users are advised to keep updated with the documentation evolution of the STM32H7 Series at www.st.com/en/
microcontrollers-microprocessors/stm32h7-series.html.

1.2 The use cases in this document

In the STM32CubelDE context, users have different ways to explore and get started with the development of
projects based on the STM32H7 Series. From the list below, select the description that best fits the use case
considered and refer to the corresponding section in this application note:

. | already have an SW4STM32 project with an ioc file:
Refer to Section 2.2 Import an SW4STM32 project with an ioc file
. | already have an SW4STM32 project without an ioc file:
Refer to Section 2.3 Import an SW4STM32 project without an ioc file
. | want to learn with and explore example projects:
Refer to Section 2.5 Import a project from the STM32CubeH7 MCU Package
. | want to start a first STM32H7 project:
—  Empty project — No STM32CubeMX support for maximum flexibility.
Refer to Section 2.4 Create an empty project based on the template in the STM32CubeH7 MCU
Package
—  STM32CubeH7 project — STM32CubeMX-managed project.
Refer to Section 2.1 Create a new STM32 project

1.3 Specific features of dual-core microcontrollers in the STM32H7 Series

The most obvious feature of a dual-core STM32H7 device is its significant performance boost that comes from the
addition of an Arm® Cortex®-M4 core besides the Arm® Cortex®-M7 core. Dual-core STM32H7 devices are also
very flexible. This application note is a simple getting-started guide to get up and running with a debug session
when both cores are running. It does not cover such additional features as the flexibility of being able to boot on
either core or the fact that each core can exist in an independent power domain to optimize energy consumption.

1.3.1 Dual-core STM32H7 project structure

When a dual-core STM32H7 project is created, its structure is automatically made hierarchical. The project
structure for single-core projects is flat. On the contrary, in a multi-core project, the hierarchical project structure is
used. When the user creates or imports a dual-core STM32H7 project, it consists of one root project together with
sub-projects, referred to as MCU projects, for each core.

The MCU projects are real CDT™ projects that can contain both build and debug configurations. On the contrary,
the root project is a simple container that allows sharing common code between the cores. The root project can
contain neither build nor debug configurations.
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Specific features of dual-core microcontrollers in the STM32H7 Series
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If the project is not shown in a hierarchical structure, this can be changed as shown in Figure 1.

Figure 1. Setting the project hierarchical view
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Create and import projects

2 Create and import projects

This chapter describes how to create or import projects for dual-core microcontrollers in the STM32H7 Series.
2.1 Create a new STM32 project

To start a new project, go to [File]>[New]>[STM32 Project] as shown in Figure 2.

Figure 2. New STM32 project

m workspace - STM32CubelDE

File Edit Source Refactor Navigate Search Project Run Window Help

New Alt+Shift+N > Makefile Project with Existing Code
Open File... C/C++ Project
L. Open Projects from File System... = STh.|32 RIOTEs
Recent Files > = Project...
Convert to a C/C++ Project (Adds C/C++ Nature)
Close Ctrl+W
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Close All Ctrl+Shift+W | Folder
Save Ctrl+S 6 Source File
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Save All Ctrl+Shift+S ¥ File from Template
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Create a new STM32 project
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Select the desired MCU or board. In the example illustrated in Figure 3, the selected board is the NUCLEO-
H74571-Q. Click on [Next >].

Figure 3. Target selection

[ sT™32 Project O e

Target Selection

Select STM32 target

Board Filter:
@ EO? O Features Large Picture Docs & Resources [ﬂ Datasheet [ Buy
Part Number Search ~ e NUCLEO-H745Z1-Q
Q |NUCLEOQ-HT45Z1-Q ~ STMicroelectronics NUCLEO-H74521-Q Board Support and Examples
Unit Price (USS): 20.0
Vendor >
[acTivE] Active
Type > Productis in mass production Mounted device: STM3ZH7457ITx
MCU/MPU Series > The STM32 Nucleo-144 boards provide an affordable and fliexible way for users 1o try out new concepts
and build prototypes by choosing from the various combinations of performance and power consumption
Other - features, provided by the STM32 microcontroller. For the compatible boards, the internal or external
SMPS significanily reduces power consumption in Run mode.
Price =29.0 The ST Zio connector, which extends the Arduine™ Uno V3 connectivity. and the ST morpho headers
[ provide an easy means of expanding the functionality of the Nucleo open development platform with a
- wide choice of specialized shields.
Oscillator Freq. = 0 (MH.
=SCI sorrred (MHz) The STM32 Nucleo-144 board does not require any separate probe as it integrates the ST-LINK
‘debugger/programmer.
The STM32 Nucleo-144 board comes with the STM32 comprehensive free software libraries and
examples available with the STM32Cube MCU Package.
Peripheral ~ Features
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@
@ NUCLEO-H745Z1-Q Mucleo144 Active 29.0
© Button 0
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[
2]
[
Z 0
O
0

AN5361 - Rev 2 page 5/28



https://www.st.com/en/product/nucleo-h745zi-q?ecmp=tt9470_gl_link_feb2019&rt=an&id=AN5361
https://www.st.com/en/product/nucleo-h745zi-q?ecmp=tt9470_gl_link_feb2019&rt=an&id=AN5361

m AN5361

Import an SW4STM32 project with an ioc file

After the target selection comes the project setup step shown in Figure 4. The Targeted Project Type setting
determines whether the project gets generated by STM32CubeMX or not. An Empty project is a skeleton of a
project that needs building upon while STM32Cube indicates an STM32CubeMX-managed project.

Figure 4. Projet setup

[LE STM32 Project O X

Project Setup
Setup STM32 project

Project Name: NUCLEO—H?4SZI—d
Use default location
Location: C:/Users/ /STM32CubelDE/workspace Browse...

Options
Targeted Language

®c Oc++

Targeted Binary Type
(®) Executable Static Library

Targeted Project Type
(®) STM32Cube () Empty

@ < Back Next = Finish Cancel

2.2 Import an SW4STM32 project with an ioc file

If the project already contains an ioc file, the easiest way to import the project into a working STM32CubelDE
environment is to copy it and open the copy through STM32CubeMX stand alone, then, in the Project Manager,
change the Toolchain / IDE to STM32CubelDE and regenerate the project.
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Import an SW4STM32 project without an ioc file

After the project is regenerated, go to [File]>[Import...] and choose to import it as an Existing projects into
workspace as shown in Figure 5.

Figure 5. Import an existing projet with an ioc file

m Import O X

Select Iﬁ

Create new projects from an archive file or directory.

Select an import wizard:

type filter text

v (= General ~
{& Archive File
1 Existing Projects into Workspace
1 File System
& Import ac6 System Workbench for STM32 Project v

Then copy the code inside the different /* USER CODE BEGIN */ blocks that exist in the project into the new
STM32CubelDE environment.

2.3 Import an SW4STM32 project without an ioc file

To make sure the project gets a hierarchical structure, the recommended way is to go to [File]>[New]>[STM32
Project] as shown in Figure 6.

Figure 6. New STM32 project

m workspace - STM32CubelDE
File Edit Source Refactor Navigate Search Project Run Window Help

New Alt+Shift+N > Makefile Project with Existing Code
Open File... C/C++ Project
. Open Projects from File System... = smsz Project
Recent Files > ™ Project...
Convert to a C/C++ Project (Adds C/C++ Nature)
Close Ctrl+W
&9 Source Folder
Close All Ctrl+Shift+W | 4 Folder
Save Ctrl+S & Source File
Save As... [i" Header File
Save All Ctrl+Shift+S  [¥ File from Template
Revert @ Class
Vigwm = Other... Ctrl+N

Select the device for the project being imported and click on [Next >].
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When setting up the project as shown in , make sure the Targeted Project Type is set to Empty and click on
[Finish].

Figure 7. Projet setup

[LE STM32 Project O X

Project Setup
Setup STM32 project

Project Name: | NUCLEO-H74571-Q
Use default location
Location: C:/Users/ /STM32CubelDE/workspace Browse...

Options
Targeted Language

®c Oc++

Targeted Binary Type
(®) Executable Static Library

Targeted Project Type

@ < Back Next = Finish Cancel
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Create an empty project based on the template in the STM32CubeH7 MCU Package

After the empty hierarchical project is generated:
1. Go to [File ]>[Import...]

2.
3.

Import the SW4STM32 project as Import ac6 System Workbench for STM32 Project
Copy and paste the project files and resources into the sub-project of the empty project as shown in Figure 8

Figure 8. Copy project content to empty sub-project

v [E NUCLEO-H74571-Q_sw4stm32
> ¥ Binaries
> @ Includes
> 2 CM4/Src
> 2 Common
> 2 Drivers
2 startup
> [8 startup_stm32h745xx_CM4.s

v [ NUCLEO-H745ZI-Q_Empty
v [T NUCLEO-H7457I-Q_Empty_CM4 (in CM4)

> @ Includes
> 18 startup_stm32h745xx_CM7.s
> & Debug_CM4 ¢ Flne
> @Dbg_cw o @
eoug- / > &2 Startup
v &CM4 ]
s e [ STM32H745ZITX_FLASH.Id
- Snc [ STM32H745ZITX_RAM.Id
~
- . v 4 E NUCLEO-H745Z1-Q_Empty CM7 (in CM7)
[& main.c
/ > @l Includes
stm32h7xx_hal_msp.c
@ stm32h7xc it ¢ Flne
stm ¥H_it.C v 5 Sic
v e CM7 - > (2 Startu
» =lInc —7 _ P
o5 [5 STM32H745ZITX_FLASH.Id
o % STM32H745ZITX RAMUId
[@ main.c
[& stm32h7x¢_hal_msp.c
[@ stm32h7xx_it.c
= NUCLEO-H74571-Q_swdstm32 Debug.hex

[@ stm32h745xx¢_flash_CM4.1d
stm32h745xx_flash_CM7.1d

Note: It is not recommended to import the . cproject, .project or .settings files.

It is important to remember to configure also the same build settings used previously while the project was in the
SW4STM32 environment. If the project contains linked resources, these need to be updated to point to the correct
resource in the file system.

This process is necessary because, when importing without any special treatment a project from SW4STM32 that
does not have an ioc file, it is imported into STM32CubelDE with a flat project structure.

24 Create an empty project based on the template in the STM32CubeH7 MCU

Package

Follow the same steps as in Section 2.3 Import an SW4STM32 project without an ioc file but use
STM32Cube_FW_H7 firmware in the STM32CubeH7 MCU Package as input.
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,l Import a project from the STM32CubeH7 MCU Package

Import a project from the STM32CubeH7 MCU Package

In order to import the STM32Cube firmware project into STM32CubelDE, go to [File]>[Import], select Existing
Projects into Workspace as shown in Figure 9, and click on [Next >].

2.5

Figure 9. Import of firmware project into STM32CubelDE

m Import

Select

Create new projects from an archive file or directory.

Select an import wizard:

type filter text
A

v = General
J& Archive File
1= Existing Projects into Workspace

2 File System
& Import ac6 System Workbench for STM32 Project
[V

El Import Atollic TrueSTUDIO Project
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Import a project from the STM32CubeH7 MCU Package

Then select the correct project. A project example is by default located at SHOME\ STM32Cube\Repository\ST
M32Cube FW H7 VX.X.X\Projects\NUCLEO-H745ZI-Q\Examples\GPIO\GPIO EXTI.

Figure 10. Firmware project selection

m Import O X
Import Projects @
-
Select a directory to search for existing Edlipse projects.
(®) Select root directory: | C:\Users\ \STM32Cube\Repository\STM32Cube_FW_H7_V1.5.0\Projects\NUCLEO-H745ZI-Q\Examples\GPIO\GPIO_EXTI - H Browse.. |
O Select archive file: N Browse...

Projects:

STM32H745Z1 Nucleo (C:\Users\ \STM32Cube\Repository\STM32Cube_FW_H7_V1.5.0\Projects\NUCLEO-H745ZI-Q\Examples\GPIO\GPIO_EXTN\SW4STM32\STM32H7457|_Nucleo) Select All

Deselect All

Options

Search for nested projects

O Copy projects into workspace

[ Close newly imported projects upon completion
[THide projects that already exist in the workspace

Working sets

[[]Add project to working sets

N Select...

Waorking sets;

® o> T

After selecting the project, click on [Finish] to import and build the project.
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Debugging

3 Debugging

This chapter highlights some of the points to bear in mind while debugging a device in the STM32H7 Series. In
the next two sections, this application note covers the configurations needed to start debug sessions with ST-
LINK GDB server and OpenOCD.

To start configuring the launch of the debug session, right click the sub-project (in this example, the Cortex®-M7)
and select [Debug As]>[STM32 Cortex-M C/C++ Application] as shown in Figure 11.

Figure 11. ST-LINK GDB server debug configuration (1 of 6) and OpenOCD debug configuration (1 of 3)

+ & Common 7 * @attention
¥ & Dri 8 )
rivers ) 9  * <h2><center>&copy; Copyright (c) 2019 STMicroelectronics.
v EINUCLEO-H745Z1-Q_CM4 (in CM4) 1@ * All rights reserved.</center></h2>
> @ Indudes 11 *
> & Common 12  * This software component is licensed by ST under BSD 3-Clau
s & Core 13  * the "License"; You may not use this file except in compli:
. & Dn 14  * License. You may obtain a copy of the License at:
rivers 15 * opensource.org/licenses/BSD-3-Claus
[ STM32H745ZITX_FLASH.Id 16 *
v ml;I:JCLEO—H74SZI—Q_( New S ,
. 4 Binari
inaries s
> @lindudes
> @& Common Open in New Window
> & Core Show In Alt+Shift+W >
> & Drivers Copy Ctrl+C ;;-;; --------------------------------
» = Debug Paste Ctrl+V
& STM32H7457ITX| % Delete Delete | */
& STM32H745ZITX ] Source 5
M NUCLEO-H745Z1-Qic  yyove  pmmmemmmmmmmmmmmmmeoooeoooooooeo
> [E STM32F413CGUx
Rename... F2
> [@ STM32L552E-EV_Templa
&1 Import...
& Export..
Build Project

Clean Project
< Refresh F5
Close Project

Close Unrelated Projects

Build Configurations >
Build Targets >
Index >

Show in Remote Systems view

O RunAs >

1 Debug As > [ 1 Local C/C++ Application
Profile As > [ 2 STM32 Cortex-M C/C++ Application
Team 2 Debug Configurations...
Compare With >

Restore from Local History...

Generate Code

@ ConverttoC++ |
% Run C/C++ Code Analysis
Configure >
Properties Alt+Enter
Note: For the rest of this section, examples are based on the NUCLEO-H755ZI-Q board.
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Setting up with ST-LINK GDB server

3.1 Setting up with ST-LINK GDB server

Since the STM32CubeMX default project puts the Cortex®-M4 in the Deepsleep mode, the [Reset behaviour]
field must be set to Connect under reset to be able to communicate with the CPU (refer to Figure 12). Make sure
to check the Halt all cores option next to it to prevent the Cortex®-M4 from starting to execute the code and end
up in the Deepsleep mode in this example. In the debug configuration, select Enable shared ST-LINK, switch to
the Startup tab and select [Add...].

Figure 12. ST-LINK GDB server debug configuration (2 of 6)

m Debug Configurations O X
Create, manage, and run configurations ’ﬁ\.
SO LEY S Name: | NUCLEO-H735-Q_CM7 Debug |

type filter text

1 C/C++ Application

] C/C++ Attach to Application
(®) Autostart local GDB server Host name or IP address localhost
[£] C/C++ Postmortem Debugger

1 C/C++ Remote Application (O Connect to remote GDB server Port number 61234

=] GDB Hardware Debugging
& Launch Group

Main [’5’ Debugger\ [ Sladup“::/ Saurce| =] gammon|
GDB Connection Settings

Debug probe |ST-LINK (ST-LINK GDE server)

& Launch Group (Deprecated) GDB Server Command Line Options

~ [@ STM32 Cortex-M C/C++ Application Interface
[ NUCLEO-H755-Q_CM4 Debug @®swp O JTAG [ ] Use specific ST-LINK S/N ~ |Sean

[ NUCLEO-H755-Q_CM7 Debug
Access port: | 0 - Cortex-M7

Reset behaviour

Type: Connect under reset > Halt all cores

Serial Wire Viewer (SWV)

D Enable
Clock Settings
Core Clock: | 16.0 MHz

SWO Clack: [2000 N <Hz
Port number: | 61235
Wait for sync packet

Cross Trigger Interface (CTI)
D Allow other cores to halt this core D Signal halt events to other cores

Misc

Verify flash download

Enable live expressions

[Log to file: C\Users\, \STM32CubelDE\workspace\NUCLEO-H755-Q\CM7\Debug' |Browse...
D External Loader: v | |Scan

Enable shared ST-LINK

Revert Apply

Filter matched 10 of 10 items

@ Debug | ‘ Close
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Setting up with ST-LINK GDB server

Startup tab - Cortex®-M7

The Cortex®-M7 debug configuration is responsible for loading both the Cortex®-M7 and Cortex®-M4 images. Go
to the Startup tab to do this as shown in Figure 13:

Figure 13. ST-LINK GDB server debug configuration (3 of 6)

m Debug Configurations O X
Create, ge, and run configurations ‘ﬁ\.

Y EIEEER

Name:‘ NUCLEO-H755-Q_CM7 Debug |

type filter text
1 C/C++ Application
] C/C++ Attach to Application
] C/C++ Postmortem Debugger
[£] C/C++ Remote Application
=] GDB Hardware Debugging

Main |°¢ Debugger | ¥ Startup| & Source‘ E Common

Initialization Commands

Load Image and Symbols

& Launch Group
Fil Build Download Load sy... Add...
# Launch Group (Deprecated) e o ownloa oad sy I—I
E

« [0 STM32 Cortex-M C/C++ Application N DeEug/NUCLEOfH]’SS*OLCM4.e:: [NUCLEO-H755-Q_CM4] « true . j true j true
[T NUCLEO-H755-Q_CM4 Debug Debug\NUCLEO-H755-Q_CM7.elf [NUCLEO-H755-Q_CMT7] See Main... true true

[Z NUCLEO-H755-Q_CM7 Debug Remove

Move down

Runtime Options

[Jset program counter at (hex):

Set breakpoint at:
Exception on divide by zero

[ Exception on unaligned access

Halt on exception

Resume

Run Commands

Filter matched 10 of 10 items Revert Apply

@ Debug | ‘ Close
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Setting up with ST-LINK GDB server

To also download the Cortex®-M4 image, click [Add...], browse the correct project and build the configuration. The
result is shown in Figure 14.

Figure 14. ST-LINK GDB server debug configuration (4 of 6)

L3 Add/Edit item O X

This file is already used.

Project: NUCLEO-H755-Q_CM4 ™

Build configuration: Debug v

Program path: Debug/NUCLEO-H755-Q_CM4.elf
File system...

Perform build
Download

Use download offset (hex)

Load symbols

Use symbol address (hex)

OK Cancel

The order in the load list is very important. The last entry in the list, marked by a green arrow (refer to Figure 13,
is the image debugged with this debug configuration; Consequently, the debugger fetches the program counter
value (PC) from this image.
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Setting up with ST-LINK GDB server

Startup tab - Cortex®-M4

As shown in Figure 15:
. Make sure that the Port number exceeds the value of the previous debug configuration by at least 3 (61238
in this example)

. Select 3 — Cortex-M4 for [Access port]
. Select None for [Reset behaviour]
. Select Enable shared ST-LINK

Figure 15. ST-LINK GDB server debug configuration (5 of 6)

m Debug Configurations O X
Create, manage, and run configurations ’ﬁ\.
Er LEe Name:| NUCLEQ-H755-Q_CM4 Debug |

type filter text

] C/C++ Application

] C/C++ Attach to Application
@ Autostart local GDB server Host name or IP address localhost
&1 C/C++ Postmortem Debugger

] C/C++ Remote Application (O Connect to remote GDB server Port number 61238

[£] GDB Hardware Debugging
& Launch Group

Main I*# Debugger| &= Startup| 3 Source‘ =] gommon‘

GDB Connection Settings

Debug probe | ST-LINK (ST-LINK GDB server) |

& Launch Group (Deprecated) GDB Server Command Line Options

~ [E STM32 Cortex-M C/C++ Application Interface
EZ NUCLEO-H755-Q_CM4 Debug ®swp  OJTAG [] Use specific ST-LINK S/N ~ | |Sean

[E NUCLEO-H755-Q_CM7 Debu
- 9 Access port: | 3 - Cortex-M4  ~

Reset behaviour

Serial Wire Viewer (SWV)

[ JEnable
Clock Settings
Core Clock: | 16.0 MHz

SWO Clock: 12000 S kHz

Port number: | 61235
Wiait for sync packet
Cross Trigger Interface (CTI)
[ ] Allow other cores to halt this core [ ] Signal halt events to other cores
Misc
Verify flash download
Enable live expressions

DLD to file: C\Users\ \STM32CubelDE\workspace\NUCLEO-H755-Q\CM4\Debug' |Browse...
g P 9

[ JExternal Loader: ~ | |Scan
Enable shared ST-LINK

Revert Apply

Filter matched 10 of 10 items

@ Debug | ‘ Close
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Setting up with ST-LINK GDB server

Go to the Startup tab and select [Edit...]>[Disable Download]. This is required since the download is already
performed by the Cortex®-M7 configuration (refer to Figure 16).

Figure 16. ST-LINK GDB server debug configuration (6 of 6)

m Debug Configurations O X

Create, manage, and run configurations 'ﬁ\.

CEReRX[BF~
type filter text

Name: | NUCLEO-H755-Q_CM4 Debug |

Main |Y3 Debugger ¥ Startup % Source‘ £ Common

] C/C++ Application

[£] C/C++ Attach to Application
] C/C++ Postmortem Debugger
1 C/C++ Remote Application

[ GDB Hardware Debugging Load Image and Symbols
& Launch Group

Initialization Commands

File Build Download Load sy... Add...

¥ Launch Group (Deprecated)
Debug\NUCLEQ-H755-Q_CM4.elf [NUC... See Main... @ false + true

~ [@ STM32 Cortex-M C/C++ Application
[Z NUCLEO-H755-Q CM4 Debug

[ NUCLEO-H755-Q_CM7 Debug
Move down

Runtime Options

[]set program counter at (hex):

Set breakpoint at:
Exception on divide by zero

[_] Exception on unaligned access

Halt on exception

Resume

Run Commands

Revert Apply

Filter matched 10 of 10 items

@ Debug | ‘ Close

The configuration is complete.
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Setting up with ST-LINK GDB server

3141 Launching the configurations
1. Launch the Cortex®-M7 configuration to download both the Cortex®-M4 and Cortex®-M7 images

2. Set the Cortex®-M7 core running so that the HSEM semaphore is released and Cortex®-M4 wakes up from
Stop mode

3. Launch the Cortex®-M4 configuration using the arrow next to the debug icon. It is in the running mode and
the user can halt it.

Figure 17. ST-LINK GDB server debug configuration launch

#Hvi®y v dRE TS yoo
[ 1 NUCLEO-H755-Q_CM4 Debug

[E 2 NUCLEO-H755-Q_CM7 Debug

% 3 New_configuration

Debug As >
Debug Configurations...

Organize Favorites...

Note: After creating the debug configurations for both cores, they are not shown in the scroll-down menu if they have
never been launched before. This is because the arrow provides access to the history of latest launches, with a
grayed “no history” message if there are none. First-time degug launch must be done through the debug
configuration wizard.

When debugging an STM32H7 device with the ST-LINK GDB server, it is possible to create a launch group, which
offers the following advantages:

. The user can launch the debug session on both cores with only one launch configuration as shown in
Figure 18.

Figure 18. ST-LINK GDB server launch group

Create, ge, and run config

Launch several other configurations sequentially

O E e B X\ B3~ Mame: Launch H757
type filter text B Launches] ] Common

C/C++ Application
C/C++ Attach to Application
C/C++ Postmortem Debugger
C/C++ Remote Application
GDB Hardware Debugging
a G Launch Group
|g Launch H757
B Launch Group (Deprecated) |
4[] STM32 Cortex-M C/C++ Applical
[ H757_CM4 Debug
[ H757_CM7 Debug

Narme Mode Action

m STM32 Cortex-M C/C++ Application:HI57_CM7 Debug  Inherit T
m STM32 Cortex-M C/C++ Application:H757_CM4 Debug  Inherit | Down |

Remove |

< 1 | v

o ——
|

Filter matched 11 of 11 items

@ [ bebug || close |

Revert | ‘ Apply |

. The user can stop both cores using the launch group. This avoids having to terminate both debug sessions
individually.
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3.1.2 Cross-trigger Interface

The cross-trigger interface is used to send halt signals from one core to the other. To enable the Cortex®-M4 to
halt the Cortex®-M7, apply the following configuration:

. In the Cortex®-M4 debug configuration: select Signal halt events to other cores
. In the Cortex®-M7 debug configuration: select Allow other cores to halt this core

Figure 19. ST-LINK GDB server debug cross-trigger interface

Cross Trigger Interface (CTI)
D Allow other cores to halt this core D Signal halt events to other cores

Note: Checking both checkboxes in both debug configurations enables both cores to halt each other.
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Select ST-LINK (OpenOCD) as the [Debug probe]. Select Autostart local GDB server for the configuration that
launches first, which is the Cortex®-M7 in the example in Figure 20. Set all the default options and verify that:
. Connect under reset is selected as [Reset Mode].

[Shared ST-LINK] is selected; this option is mandatory to run the multicore target.

Figure 20. OpenOCD debug configuration (2 of 3)
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Connection Setup
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< >
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Filter matched 10 of 10 items = Lk
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Create the debug configuration for the other core, which is the Cortex®-M4 in the example in Figure 21:
. Select ST-LINK (OpenOCD) as the [Debug probe]
. Select Autostart local GDB server as default

Make sure that the Port number exceeds the value of the previous debug configuration by at least 2 (3335 in
this example)

Open [Generator Options] and select Core reset as [Reset Mode]

Figure 21. OpenOCD debug configuration (3 of 3)
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Generator Options
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Connection Setup e e
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Interface: |Swd ~ ‘
Enable debug in low power modes
Frequency: |8MHz V‘
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The configuration of the Startup tab is the same as with the ST-LINK GDB server probe for both debug

configurations (refer to Startup tab - Cortex®-M7 and Startup tab - Cortex®-M4 in Section 3.1 Setting up with ST-
LINK GDB server).
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3.21 Launching the configurations

After both debug configurations are set up, save them and click on the arrow next to the debug icon to make sure

launching the autostarting local GDB server first (the Cortex®-M7 in this example). After this first launch, click on
the same arrow again and launch the other configuration.

Figure 22. OpenOCD debug configuration launch

Fry@IyvidRETIEHYFH OO Y O
[E 1 NUCLEO-H755-Q_CM4 Debug OpenQCD

[T 2 NUCLEO-H755-Q_CM7 Debug OpenQCD

@ 3 New_configuration

Debug As >
Debug Configurations...

Organize Favorites...

Note: After creating the debug configurations for both cores, they are not shown in the scroll-down menu if they have
never been launched before. This is because the arrow provides access to the history of latest launches, with a

grayed “no history” message if there are none. First-time degug launch must be done through the debug
configuration wizard.

When debugging an STM32H7 device with OpenOCD, it ispossible to create a launch group, which offers the
following advantages:

. The user can launch the debug session on both cores with only one launch configuration.

Figure 23. Launch OpenOCD debug on both cores
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Remove |

T F——

Filter matched 11 of 11 items [ Revet || Appy |

@ I Debug I [ Close ]
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. The user can stop both cores using the launch group. This avoids having to manually terminate both debug
sessions individually. In Figure 24, the launch group in pink handles each of the cores in green.

Figure 24. Stop OpenOCD debug on both cores
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Lﬁ 5T-LINK (OpenOCD)
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= Reset_Handler() at startup_stm32h757xihy.=:83 0x810034 e
[55 C:/ST/STM32CubelDE_1.1.019rc3/STM32CubelDE/plugins/com.st)

3.2.2 Cross-trigger interface

The cross-trigger interface is used to send halt signals from one core to the other. To enable the Cortex®-M4 to
halt the Cortex®-M7, apply the following configuration:

. In the Cortex®-M4 debug configuration: select Signal halt events to other cores
. In the Cortex®-M7 debug configuration: select Allow other cores to halt this core

Figure 25. OpenOCD debug cross-trigger interface

Cross Trigger Interface (CTI)
[ ] Allow other cores to halt this core [_] Signal halt events to other cores

Note: Checking both checkboxes in both debug configurations enables both cores to halt each other.
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